What's the source of this texture compression?

edited January 2017 in Questions

Hey all.

I'm using a custom texture on a hero shader, as the diffuse.

Here's a portion the texture as seen in the preview in Source's material editor texture preview (clicking on the texture): https://i.imgur.com/V0JSShU.png

And here's the same portion on the preview in the Material Editor (the mesh on the right): http://i.imgur.com/D9yhXZ9.png

Anyone know what's causing this ugly compression? Don't see any mipmapping options. Is there a way to improve it? Thanks, for any help you guys can offer.

Comments

  • edited January 2017 Posts: 28

    "Solved" this issue.

    It was mipmapping. You can disable mipmapping by clicking the Texture Settings button in the Material Editor

    http://i.imgur.com/ND4mDPq.png

    and then check No Mips.

    http://i.imgur.com/GaKUvNu.png

    ~~I don't know enough about mipmapping to comment on the ramifications of disabling it. I'm researching it now; I'll update if I find anything good.~~

    Mips are downres'd versions of textures, that essentially act as LOD's for a texture. It looks like Source's highest resolution Mip isn't as high as the base texture it's from; but the object should generally render fine in game (even if it looks rough in the editor).

    If you really need better resolution, import a higher resolution base texture (this will have the downside of increasing load times significantly).

    I don't know what the performance impact of "No Mips" would be, but I don't recommend it.